Improvements for Zen Cart Super Orders posted today

  • Batch Print and Batch Status update will permit either starting or ending order number (in addition to handling both).
  • Batch Print and Batch Status update screens narrowed so they fit into a the admin window instead of requiring a scroll right.

You can get the latest Super Orders from the Zen Cart Free Software Add Ons area.

Switching from TYPE=MyISAM to ENGINE=MyISAM for Zen Cart Mods

If you have a newer version of MySQL, you may notice an error when you run SQL scripts (using Admin->Tools->Install SQL Patches) during mod installs on your Zen Cart.  The error will look something like this:

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 1
in:
[CREATE TABLE foo1 ( coupon_id int(11) NOT NULL auto_increment, orders_id int(11) NOT NULL, copy_from_coupon_code varchar(32) NOT NULL default '', new_coupon_name varchar(32) NOT NULL default '', customers_id int(11) NOT NULL default '0', PRIMARY KEY (coupon_id), KEY idx_coupon_code (copy_from_coupon_code), KEY idx_coupon_name(new_coupon_name), KEY idx_customers_id (customers_id) ) TYPE=MyISAM;]
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Solving this issue is straightforward: in the .sql file you are running, just change

TYPE=MyISAM

to

ENGINE=MyISAM

Of my Zen Cart mods, the following mods have a table create with TYPE=MyISAM, which could cause this issue:

 

Super Orders for Zen Cart – new fixes

v3.0.1 (updated by That Software Guy)

  • Adding a comment to an order with an apostrophe causes SQL failure – fixed
  • Not installing Ty Tracker means Super Orders Print will fail – fixed
  • Display all comments in Invoice
  • Display all comments in Packing Slip

You can get the updated Super Orders for Zen Cart from the Zen Cart Free Software Add Ons.

Zen Cart 1.5.0 – That Software Guy’s Mods and Upgrading

All of my mods are Zen Cart 1.5.0 ready.  Some of them require no changes, but the ones that require a refresh are listed below.  Note that Contributions are free software, available on the Zen Cart forum; extensions are paid software, whose prices are listed on each extension’s page.  Prior purchasers may update extensions for $10 each.

I am now taking requests to upgrade 1.3.9 Zen Cart installations to Zen Cart 1.5.0.  Please contact me for details.  Thank you!

Zen Cart 1.3.8 and Prior Versions

If you haven’t yet upgraded from Zen Cart 1.3.7 or 1.3.8 to Zen Cart 1.3.9h, the list of reasons gets longer every day.  More fixes, more security, better performance – don’t miss this opportunity to improve your shop.  Let me know if you need help!

If you have not upgraded yet, please be sure you have the most critical Zen Cart fixes for pre-139 Releases.