Mixed Content Error in Firefox when using CKEditor in Zen Cart

If you have upgraded to FF 23 and suddenly your CKEditor is not working (in admin->catalog->categories/products), take heart: it’s a one line fix to get it back again. Edit

<your renamed admin>/includes/ckeditor.php

and change the inclusion of jsapi to not use a protocol, i.e.

<script type=”text/javascript” src=”//www.google.com/jsapi”></script>

instead of
<script type=”text/javascript” src=”http://www.google.com/jsapi”></script>

and you should be all set. You will NOT see this issue in FF 22 and prior, only FF23 (and perhaps higher).

NOTE: The latest CKEditor package in the ZC Plugins area already has this change in it.

This was originally posted by That Software Guy on the Zen Cart forum on 8/28/13.

Numinix Fast and Easy Checkout and Gift Wrapping

A client asked me to install my Gift Wrapping module on his site, which already had Fast and Easy Checkout. In doing so, I found and fixed some bugs in Numinix’s FEC integration of Zen Cart Gift Wrapping.

These bugs are fixed in the latest version of FEC, but it’s a pretty big upgrade if you already have the mod installed, so my fix might be easier to manage.